Welcome to Carver Yachts Owners Forum

We are a boating forum for owners of Carver Yachts to enthusiastically discuss all aspects of Carver Boat ownership. Whether you are looking for your first Carver or currently own one, you are sure to feel at home on CarverYachtOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Port Engine Continues To Run Even With Key Removed...

Discussion of batteries, chargers, wiring, generators, distribution panels, battery switches, etc.
User avatar

Topic author United States of America
mbjezior
Scurvy Dog
Scurvy Dog
Posts: 8
Joined: September 24th, 2017, 10:34 am
Vessel Info: Carver 370 Aft Cabin
Location: Bay City, MI

Port Engine Continues To Run Even With Key Removed...

Postby mbjezior » August 9th, 2018, 9:09 pm

Has happened twice now...go to shut down when docked and port motor continues to run when in the off position - key can be removed yet still runs...only way to shut down is by port fuel valve to OFF.
Thought it was a bad ignition switch- replaced it- tested it- worked normally. Then when back at dock omce again it failed to shut down.
I’ve been reading a ton and maybe an alternator diode? Have an alternator on order..
Could be the wiring harness maybe?
Has anyone had this issue?

1994 Carver 370 Aft Cabin
Crusader 454XL w Holley Fuel Injectors

User avatar

Canada
bud37
Admiral
Admiral
Posts: 1414
Joined: April 23rd, 2015, 10:22 pm
Has thanked: 195 times
Been thanked: 275 times

Re: Port Engine Continues To Run Even With Key Removed...

Postby bud37 » August 9th, 2018, 9:49 pm

Interesting.....only seen that once, ......do you have the engine wiring diagram, is there a main start relay in it that feeds the ignition and fuel pump, may be stuck or sticking....have your alternator tested before you replace it, could be nothing wrong with it....thats all I can think of without seeing a schematic....
User avatar

United States of America
km1125
Admiral
Admiral
Posts: 625
Joined: February 28th, 2017, 6:04 pm
Been thanked: 145 times

Re: Port Engine Continues To Run Even With Key Removed...

Postby km1125 » August 9th, 2018, 9:53 pm

Any other accessories wired into that engine that are acting 'funky'? A bad ground that's common between two accessories can 'backfeed' voltage into the IGN circuit and fool the ECM into thinking the key is still on.

I did this inadvertently to a truck once. Wired an LED into the ignition so it would light when the key was OFF and go OFF when the key was ON. Worked great, except there was a trickle of current going through when the IGN was on, so if the vehicle was started, it would not shut off. A bad ground between two accessories can do the same thing.
User avatar

Canada
Midnightsun
CYO Supporter
CYO Supporter
Posts: 418
Joined: March 27th, 2016, 2:27 pm
Vessel Info: The Midnight Sun
2007 41CMY
Volvo D6-370's
Location: Montreal, Canada
Has thanked: 26 times
Been thanked: 122 times

Re: Port Engine Continues To Run Even With Key Removed...

Postby Midnightsun » August 10th, 2018, 12:21 am

Boat ignitions in general are rather simplistic, 3 wires is all there is. One has constant 12v, one is ignition feed and the other is starter feed. Connect the 12v to ignition and you have power to run the engine, this is the one you need to trace back which should be purple in colour. Momentarily connect the 12v to the starter and you operate the starter motor. As mentioned, a led light interconnected to this power source does have a small amount of current which could trick the engine into thinking the ignition is off. Think back to anything electric you may have added in the recent past and disconnect to test.

Good luck in your findings and report back with the solution to the issue.
Cheers, Hans
2007 Carver 41 CMY
Twin Volvo D6-370's
Montreal, Canada
Midnight Sun I Photos

Canada
Viper
CYO Supporter
CYO Supporter
Posts: 2229
Joined: July 10th, 2015, 9:58 pm
Vessel Info: 1989 Carver 3807
Location: Ontario, Canada
Has thanked: 77 times
Been thanked: 428 times

Re: Port Engine Continues To Run Even With Key Removed...

Postby Viper » August 10th, 2018, 6:46 am

Could be anything mentioned above including an alternator diode. In my experience the alternator being the cause of this particular symptom is rare but it does happen.
User avatar

United States of America
km1125
Admiral
Admiral
Posts: 625
Joined: February 28th, 2017, 6:04 pm
Been thanked: 145 times

Re: Port Engine Continues To Run Even With Key Removed...

Postby km1125 » August 10th, 2018, 9:51 am

I can't see where one of the normal "alternator diodes" could cause this. Perhaps they mean a diode in the regulator for the alternator (which could be in the alternator when the regulator is included).
User avatar

Canada
bud37
Admiral
Admiral
Posts: 1414
Joined: April 23rd, 2015, 10:22 pm
Has thanked: 195 times
Been thanked: 275 times

Re: Port Engine Continues To Run Even With Key Removed...

Postby bud37 » August 10th, 2018, 12:04 pm

One of those things that rarely crops up that makes you consider how a gas engine is actually turned off....anyhow he has a Holley retrofit I think from his signature, so it may have the relays, who knows.... alt. backfeed will do it as well....hopefully he posts the resolution.
User avatar

Topic author United States of America
mbjezior
Scurvy Dog
Scurvy Dog
Posts: 8
Joined: September 24th, 2017, 10:34 am
Vessel Info: Carver 370 Aft Cabin
Location: Bay City, MI

Re: Port Engine Continues To Run Even With Key Removed...

Postby mbjezior » August 10th, 2018, 9:03 pm

Won’t be until Tuesday before I can check/test the alternator for diode failure...will do that first and report back. Have an alternator on order as backup, also will change out the ignition relay too...

Canada
Viper
CYO Supporter
CYO Supporter
Posts: 2229
Joined: July 10th, 2015, 9:58 pm
Vessel Info: 1989 Carver 3807
Location: Ontario, Canada
Has thanked: 77 times
Been thanked: 428 times

Re: Port Engine Continues To Run Even With Key Removed...

Postby Viper » August 11th, 2018, 6:45 am

One of the benefits of having two engines is that you can use that to your advantage as a diagnostic tool. When in doubt, swap a part from one engine to another and see if the fault follows the part.
User avatar

Topic author United States of America
mbjezior
Scurvy Dog
Scurvy Dog
Posts: 8
Joined: September 24th, 2017, 10:34 am
Vessel Info: Carver 370 Aft Cabin
Location: Bay City, MI

Re: Port Engine Continues To Run Even With Key Removed...

Postby mbjezior » August 14th, 2018, 10:36 pm

Results...tested both the good alternator and the suspected “bad” alternator diodes and all checked out good- same on both.
I did replace the ignition relay on the port side- will run it wednesday for a period of time and will report back...

Return to “Electrical”



Who is online

Users browsing this forum: No registered users and 1 guest