Welcome to Carver Yachts Owners Forum

We are a boating forum for owners of Carver Yachts to enthusiastically discuss all aspects of Carver Boat ownership. Whether you are looking for your first Carver or currently own one, you are sure to feel at home on CarverYachtOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Engine starter won't engage

GAS engine, transmission and generator repair and maintenance discussion forum.
User avatar

Topic author United States of America
dsouder
Scurvy Dog
Scurvy Dog
Posts: 5
Joined: June 1st, 2015, 9:27 am
Vessel Info: 1994 Carver 300 Aft Cabin
Location: Indianapolis area
Been thanked: 1 time
Contact:

Engine starter won't engage

Postby dsouder » September 12th, 2015, 10:04 pm

I have a '94 Carver 300 AFT Cabin with 350 Mercursier engines. Just out of no where, when I engage the starter ignition switches, nothing happens. Now I haven't used this boat much this season. But have only ran it about 3 times all season. But each time it has fired right up. I have tried nudging the transmission levers while trying to start just to be sure it wasn't the neutral safety switches. But that didn't do anything. Out of necessity, I did heavily wash/hose down the helm one day. Shortly there after I started having this problem. I thought that I may have shorted the ignition switches some way so I have replaced those....No Change. Any suggestions?????

User avatar

United States of America
CYO Admin
CYO Administrator
CYO Administrator
Posts: 412
Joined: January 30th, 2013, 9:07 am
Location: Florida
Has thanked: 262 times
Been thanked: 23 times

Re: Engine starter won't engage

Postby CYO Admin » September 13th, 2015, 7:30 am

Have you check your battery connections?
User avatar

Topic author United States of America
dsouder
Scurvy Dog
Scurvy Dog
Posts: 5
Joined: June 1st, 2015, 9:27 am
Vessel Info: 1994 Carver 300 Aft Cabin
Location: Indianapolis area
Been thanked: 1 time
Contact:

Re: Engine starter won't engage

Postby dsouder » September 13th, 2015, 7:58 am

No I haven't but will today. Thank you for your reply

Canada
Viper
CYO Supporter
CYO Supporter
Posts: 3798
Joined: July 10th, 2015, 9:58 pm
Vessel Info: 1989 Carver 3807
Location: Ontario, Canada
Has thanked: 227 times
Been thanked: 918 times

Re: Engine starter won't engage

Postby Viper » September 13th, 2015, 10:55 am

Sounds like something common to both engines. As mentioned, check that battery connections are clean and tight, as well as the connections and wiring at the helm. Test the batteries to ensure they are fully charged. Short of that, it's likely a component failure like slave solenoids but it would be a real coincidence for both to go at the same time. You never know though. Have someone in the engine compartment listen for a click when you try and start the engines. If they hear a click, you'll know the control circuit is working properly.

Return to “Gas Engines/Transmissions”



Who is online

Users browsing this forum: No registered users and 6 guests