Welcome to Carver Yachts Owners Forum

We are a boating forum for owners of Carver Yachts to enthusiastically discuss all aspects of Carver Boat ownership. Whether you are looking for your first Carver or currently own one, you are sure to feel at home on CarverYachtOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Grey water pump system

Discussion of AC's, plumbing and sanitation related issues.
User avatar

Topic author United States of America
capgattis
Scurvy Dog
Scurvy Dog
Posts: 8
Joined: January 7th, 2018, 6:47 pm
Vessel Info: owner 53' carver voyager. 2003
Location: Bahamas
Has thanked: 7 times
Been thanked: 6 times

Grey water pump system

Postby capgattis » April 10th, 2018, 11:47 pm

In my 530 voyager I have the grey water ending up in bilge instead of being pumped overboard. The grey water pump seems to work ok. Is this a broken hose problem? :captain:

User avatar

United States of America
g36
Commander
Commander
Posts: 337
Joined: April 7th, 2014, 6:07 pm
Vessel Info: 1997 Carver 405
Location: Soddy Daisy TN.
Has thanked: 3 times
Been thanked: 64 times

Re: Grey water pump system

Postby g36 » April 11th, 2018, 9:45 am

Pump seems ok does that mean you hear or? Have someone run sink or whatever while you are at the sump and see what is happening. Verify the float switch in your sump box is working properly could be the sump box is spilling over. Pump may be clogged with hair or grease . Pull it out and check the inlet at base its just a small bilge pump in a box. If these check out then I would look st fittings at each end and where it exits the boat make sure nothing cracked and leaking when pump turns on. Shouldn't be to hard to troubleshoot this
1997 Carver 405
Crusader xli
The Black Pearl
Soddy Daisy Tn.
User avatar

United States of America
A Lee
Scurvy Dog
Scurvy Dog
Posts: 8
Joined: April 1st, 2018, 9:53 am
Vessel Info: 2005 56' Voyger
Location: Mississippi
Been thanked: 2 times

Re: Grey water pump system

Postby A Lee » May 10th, 2018, 1:55 pm

I installed an new Rule 5300 and float switch in my grey water tank. All went well except the factory mount for the float switch is a little higher than it should be. I was able to solve the problem by simply adding a small piece of a key float to the bottom of the float with 5200 adhesive. It allows the float to activate the pump prior to the water reaching the very top of the holding tank. I hope this helps.

Return to “AC/Heat, Plumbing & Sanitation”



Who is online

Users browsing this forum: No registered users and 0 guests