Welcome to Carver Yachts Owners Forum

We are a boating forum for owners of Carver Yachts to enthusiastically discuss all aspects of Carver Boat ownership. Whether you are looking for your first Carver or currently own one, you are sure to feel at home on CarverYachtOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Princess Oven Element Not Working on 3 Burner Electric Stove

Discussion of batteries, chargers, wiring, generators, distribution panels, battery switches, etc.
User avatar

Topic author
mrsparkj
Scurvy Dog
Scurvy Dog
Posts: 18
Joined: July 21st, 2015, 1:15 pm
Vessel Info: 1987 Carver Aft Cabin
Has thanked: 3 times
Been thanked: 1 time

Princess Oven Element Not Working on 3 Burner Electric Stove

Postby mrsparkj » March 26th, 2016, 1:09 pm

Question with regards to a Princess Oven. I have a 1987 32' Carver Aft Cabin, with original Princess 3 burner / electric stove oven. I live aboard her during the winter and when cooking noticed the oven element stopped working. My broiler element works fine and hear a click when I turn the oven setting from 450 to 500. I ordered a replacement oven heater element, connected and still the oven does not heat in the 200 - 450 settings. Any ideas. Is there a switch that engages when you close the oven door?? Looking for any trouble shooting ideas. Thanks!


Canada
Viper
CYO Supporter
CYO Supporter
Posts: 2229
Joined: July 10th, 2015, 9:58 pm
Vessel Info: 1989 Carver 3807
Location: Ontario, Canada
Has thanked: 77 times
Been thanked: 428 times

Re: Princess Oven Element Not Working on 3 Burner Electric Stove

Postby Viper » March 26th, 2016, 11:42 pm

No door switch that I know of. Have you confirmed that you're getting 120 volts at the element? If you are, then the element is bad or is the wrong one and it's designed for a 220 volt unit for example.

If there is no voltage at the element, start tracing the circuit back from there. If I recall, you'll have an oven selector switch as well as the thermostat. Check for voltage on both sides of the switch and the t-stat. With the t-stat turned on, you should have voltage though it. If you don't but have voltage up to it, the problem is the t-stat. Check all connections to make sure they are clean, corrosion free and tight.

If the broiler works, that indicates the broiler side of the t-stat is working. You can try swaping the broiler wire at the t-stat with the lower element wire. This should light up the lower element. If it does, the bake side of the t-stat has failed.

Careful here, you're dealing with 120 volts. You can use a meter or a voltage detector pen (everyone should have one on board). If you're handy with a meter, you can do a continuity check of the switch and t-stat in the "on" position.
User avatar

Topic author
mrsparkj
Scurvy Dog
Scurvy Dog
Posts: 18
Joined: July 21st, 2015, 1:15 pm
Vessel Info: 1987 Carver Aft Cabin
Has thanked: 3 times
Been thanked: 1 time

Re: Princess Oven Element Not Working on 3 Burner Electric Stove

Postby mrsparkj » March 27th, 2016, 9:26 am

Viper, appreciate the troubleshooting explanation! The diagram I have is VERY old and hard to follow. Going down next weekend to do some maintenance and will follow your instructions! Will let you know how I make out. Scott

Canada
Viper
CYO Supporter
CYO Supporter
Posts: 2229
Joined: July 10th, 2015, 9:58 pm
Vessel Info: 1989 Carver 3807
Location: Ontario, Canada
Has thanked: 77 times
Been thanked: 428 times

Re: Princess Oven Element Not Working on 3 Burner Electric Stove

Postby Viper » March 27th, 2016, 9:44 am

Even if it's a 220 volt element installed in a 110V stove, the element should still heat up a little if the circuit is working properly.
User avatar

Topic author
mrsparkj
Scurvy Dog
Scurvy Dog
Posts: 18
Joined: July 21st, 2015, 1:15 pm
Vessel Info: 1987 Carver Aft Cabin
Has thanked: 3 times
Been thanked: 1 time

Re: Princess Oven Element Not Working on 3 Burner Electric Stove

Postby mrsparkj » April 13th, 2016, 7:50 am

Viper...it was the t-stat. Got it working, really appreciate your troubleshooting solutions!

Canada
Viper
CYO Supporter
CYO Supporter
Posts: 2229
Joined: July 10th, 2015, 9:58 pm
Vessel Info: 1989 Carver 3807
Location: Ontario, Canada
Has thanked: 77 times
Been thanked: 428 times

Re: Princess Oven Element Not Working on 3 Burner Electric Stove

Postby Viper » April 13th, 2016, 9:24 pm

Sweet. Good job :down:

Return to “Electrical”



Who is online

Users browsing this forum: No registered users and 1 guest