Welcome to Carver Yachts Owners Forum

We are a boating forum for owners of Carver Yachts to enthusiastically discuss all aspects of Carver Boat ownership. Whether you are looking for your first Carver or currently own one, you are sure to feel at home on CarverYachtOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

2004 Carver 360 SS Bow Truster Problem

Anything related to the operation of your boat. Steering, Bilge Pumps, thru-hulls, bottom paint, etc.
User avatar

Topic author
wnunes
Scurvy Dog
Scurvy Dog
Posts: 2
Joined: April 24th, 2015, 12:15 pm
Vessel Info: 2004 Carver 360 Sport Sedan

2004 Carver 360 SS Bow Truster Problem

Postby wnunes » May 3rd, 2015, 8:11 pm

Hi,
Ran my boat all year long with no problem with my Bow Truster, winterized for the winter and the boat is back in the water, but unfurtunetely the bow truster is not spinning anymore, lights are on i can hear a click but no movement, can anyone help??

Thanks
Will

User avatar

United States of America
waybomb
CYO Moderator
CYO Moderator
Posts: 1968
Joined: February 5th, 2013, 9:24 pm
Vessel Info: 1987 3697 Carver Mariner
1988 Cougar 46 Kevlar Vee offshore
1969 15' Glaspar / 1969 Johnson Electrmatic 85
1964 Barron Flat bottom drag boat
A couple of dinghies
Location: Saint Joseph and Trenton, MI
Has thanked: 41 times
Been thanked: 283 times

Re: 2004 Carver 360 SS Bow Truster Problem

Postby waybomb » May 4th, 2015, 1:02 pm

The click you hear is probably the relay acting. Is the breaker for the main power to the thruster motor blown? Or a mainline fuse? There may be a separate control circuit, so you'll hear the relay clicking and actuating, but no power available to go through the now-closed circuit.

Check for 12v on the line side of the solenoid. If not there, go backwards and find out where the open is. If you do have 12v at line side, then check for 12v on load side, when somebody operates the switch and you hear the relay click. If no voltage on load side, but yes voltage on line side, replace the relay. If you have power on both sides, either something is stuck with the prop mechanism or the motor is bad (doubt that to be the problem).

I am guessing a blown mainline fuse or a popped breaker as I am guessing you tried it in both directions and neither way worked, correct? You probably have a relay for each direction, but only one main power line to them.

ps - I've never worked on thrusters so I may be all wet on this one. But it's what I would do had I had a non-functioning clicking thruster
Thanks
Fred
1964 Barron Flatbottom with BBC Chevy
1969 Glaspar Avalon /1969 Johnson Electromatic 85
1987 Carver Mariner
1988 Cougar Kevlar 46' with triple blown 572s
http://s4.beta.photobucket.com/user/waybomb/library/
Past - 1988 2807, 1989 4207 Aft

Return to “General Repairs & Maintenance”



Who is online

Users browsing this forum: No registered users and 25 guests