Welcome to Carver Yachts Owners Forum

We are a boating forum for owners of Carver Yachts to enthusiastically discuss all aspects of Carver Boat ownership. Whether you are looking for your first Carver or currently own one, you are sure to feel at home on CarverYachtOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

A very strange Issue, We need Help

GAS engine, transmission and generator repair and maintenance discussion forum.
User avatar

Topic author
canalside
Scurvy Dog
Scurvy Dog
Posts: 1
Joined: December 7th, 2015, 6:03 pm
Vessel Info: 2000 "406" aft cabin

A very strange Issue, We need Help

Postby canalside » December 7th, 2015, 6:23 pm

I have a real strange issue. I have a 7.4 liter Volvo penta engines. The engine ran for 58 days as we traveled south and every thing was great. IT sat 2 wekks. Engines Flushed with fresh water when we stopped. It ran great for 5 to 7 minutes and then increased RPM to 2600 and would not go down. Switched AIC valve. no Help. We swithched the computer and this was not the issue. Ohmed and continuity to wires to value no issue. Checked wires to ground no issue. What can it be. We need help!!!!

User avatar

United States of America
Ramsport47
Commander
Commander
Posts: 376
Joined: February 10th, 2013, 7:13 am
Vessel Info: 1998 Carver 310 Santego
Has thanked: 72 times
Been thanked: 53 times

A very strange Issue, We need Help

Postby Ramsport47 » December 8th, 2015, 6:14 am

Not sure if that vintage engine would have a throttle position sensor, but, if it does, the cable hooks up to it and it tells the engine what to run at. If it fails, you can have an issue like this
Kenny
1998 Carver 310 Santego
T-Merc 350 Mag MPI (300hp)
Port: Cedar Point Marina, Sandusky, Ohio
User avatar

Canada
Lyndon670
Admiral
Admiral
Posts: 657
Joined: July 29th, 2013, 11:35 pm
Vessel Info: 2000 Carver 506
Volvo TAMD74EDC
Location: Georgian Bay
Has thanked: 124 times
Been thanked: 134 times

A very strange Issue, We need Help

Postby Lyndon670 » December 8th, 2015, 4:55 pm

+1 with Kenny. Try disconnecting the TPS.

Also think fuel pressure regulator problem. Did you shut it down and restart to see if it immediately increased to 2600 or if there was still a delay?
Lyndon,
2000 Carver 506
FOXY JOE
Volvo 7.4TAMD
Queens Cove Marina
Georgian Bay, Ontario

Return to “Gas Engines/Transmissions”



Who is online

Users browsing this forum: km1125 and 15 guests