Welcome to Carver Yachts Owners Forum

We are a boating forum for owners of Carver Yachts to enthusiastically discuss all aspects of Carver Boat ownership. Whether you are looking for your first Carver or currently own one, you are sure to feel at home on CarverYachtOwners.com

You are currently viewing our board as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

tankwacht system not working

Discussion of AC's, plumbing and sanitation related issues.
User avatar

Topic author
michelml54
Scurvy Dog
Scurvy Dog
Posts: 7
Joined: September 22nd, 2014, 2:07 pm
Vessel Info: carver 325 motor yacht 1998

tankwacht system not working

Postby michelml54 » September 25th, 2015, 10:19 am

gentlemen, my toilet tankwacht system on my boat indicate only when it is half full
is there something to be done to re-activate the systemn. Maybe a strong liquid or powder cause i tried with different products that marinas sell especially for that but it did not work

May be somebody has a good suggestion

Michel


mlafortune@canelco.net

User avatar

SHEMP
Deck Hand
Deck Hand
Posts: 51
Joined: March 7th, 2013, 7:43 pm
Vessel Info: 2000 CARVER 456 MY
Full Bridge and aft deck enclosure
Originally purchased in Staten Island
Second owner also purchased in Staten Island in 2012
Now berthed in Toronto Canada
A wonderful and fully appointed luxury yacht.
Location: Toronto Ontario Canada
Has thanked: 7 times
Been thanked: 4 times

Re: tankwacht system not working

Postby SHEMP » September 27th, 2015, 1:10 pm

Michael, the Tankwatch sensor probes are installed on top of your holding tanks(s)
There are three Sensor rods . One indicates empty Green Light
One indicates Half Yellow light
the other is for a Full Tank Red.
All are adjustable . You might have to remove and clean the sensor Floats, (sorry but stinky and dirty job).
You might have a build up of dry waste or scum on the probes , a good quality waste tank cleaner might solve your problem without making any adjustments, this would be my first course of action.
Do you use Sealand products? These are recommended.
Let me know if this info helped you
Victor
User avatar

United States of America
RGrew176
Admiral
Admiral
Posts: 3801
Joined: August 17th, 2015, 4:07 am
Vessel Info: 1981 Carver 3007 Aft Cabin
Location: Southgate, MI.
Has thanked: 53 times
Been thanked: 351 times

Re: tankwacht system not working

Postby RGrew176 » September 27th, 2015, 7:32 pm

A friend of mine had a similar problem. What he did that worked was he put some Dawn detergent about a half bottle in a bucket of hot water then poured it into his tank. Then he filled the tank about half way with hot water. It was a windy day and Lake Erie was rough so he took his boat out into the lake and let the solution slosh around in the tank for about an hour. After he came in off the lake he pumped the head. As he used his holding tank after that the sensors worked once again. He figured it was crud that caused them to stop working. Not saying it would work in your situation but it worked in his.
Rick Grew

1981 Carver 3007 Aft Cabin

2004 Past Commodore
West River Yacht & Cruising Club
www.wrycc.com

Return to “AC/Heat, Plumbing & Sanitation”



Who is online

Users browsing this forum: mjk1040 and 0 guests